Wijmo Core Compatibility

Compatibility

Operating System for Deployment
  • Windows 10
  • Windows 8.1
  • Windows 8
  • Windows Server 2012
  • Windows 7
Architecture of Product
  • 32Bit
  • 64Bit
Product Type
  • Component
Component Type
  • HTML5
  • JavaScript
  • Angular
  • AngularJS
  • jQuery
  • Knockout
  • React
  • Vue.js
  • AJAX
Compatible Containers
  • Microsoft Internet Explorer 11
  • Microsoft Internet Explorer 10.0
  • Microsoft Internet Explorer 9.0
  • Mozilla Firefox 21
  • Mozilla Firefox 20
  • Mozilla Firefox 19
  • Mozilla Firefox 18
  • Mozilla Firefox 17
  • Mozilla Firefox 16
  • Mozilla Firefox 15
  • Mozilla Firefox 14
  • Mozilla Firefox 13
  • Mozilla Firefox 12
  • Mozilla Firefox 11
  • Mozilla Firefox 10
  • Mozilla Firefox 9
  • Mozilla Firefox 8
  • Mozilla Firefox 7
  • Mozilla Firefox 6
  • Mozilla Firefox 5
  • Mozilla Firefox 4
  • HTML5 Builder XE3
  • jQuery 1.3
  • jQuery 1.4

Prerequisites

Wijmo 5 requires Internet Explorer 9 or better to leverage the following technologies:

  • ECMAScript 5: The ECMAScript 5 standard adds support for property getters and setters, it also adds many other significant enhancements, like the bind method that allows you to specify the value of the 'this' parameter in your callbacks. There are also new array methods that can save a lot of time.
  • SVG: Modern browsers implement SVG, which makes it easier to create amazing visual representations of your data. Wijmo leverages SVG directly, without the overhead that would be required if it had to support legacy browsers.
  • AngularJS: AngularJS is one of the most popular and powerful JavaScript application frameworks today.
  • Bootstrap: Bootstrap is one of the easiest, most powerful, and most popular CSS frameworks available.
  • jQuery 2.0: jQuery was one of the first popular JavaScript libraries to release a version targeting modern browsers. Wijmo takes advantage of that as well, using jQuery 2.0 and benefiting from its smaller size and better performance.
  • TypeScript: Wijmo was written in TypeScript, taking advantage of type-checking and OOP concepts such as modules, classes, and inheritance. The output is still pure JavaScript, so you can use either language in your own development work.
  • Mobile Devices: Wijmo 5 was designed with mobile browser support built in from the start. Responsive layouts and touch support were major considerations in the design and implementation of every Wijmo 5 control.


ComponentOne realize that some scenarios require support for legacy browsers (Internet Explorer 8 and earlier). For that reason, they will continue to maintain versions of the original Wijmo (Wijmo 3(Professional)) for as long as customers require it. If you need to support IE8 and earlier, keep using the original Wijmo. ComponentOne will maintain and support it as usual. If you are ready to move to HTML5 and modern browsers then it is recommended that you use Wijmo 5.

Wijmo 3 requires internet Explorer 6 or better.

SpreadJS requires:

  • Microsoft IE9 (Uncheck the Display intranet sites in Compatibility View option under Tools menu)
  • Mozilla FireFox
  • Safari
  • Google Chrome
  • The browser must support HTML 5