The Databases tab provides users with information regarding their:
Summary. Allows you to view the status of all the databases on the selected SQL Server instance.
Configuration. Allows you to view the configuration settings of the databases on the selected SQL Server instance.
Files. Allows you to see the file statistics for each of your databases on the selected SQL Server instance.
Backup & Restore. Allows you to view the backup and restore history of each database on the selected SQL Server instance.
Tables & Indexes. Allows you to view statistics for all the tables and indexes on a particular database.
수정 사항
Alerts
Resolved an issue causing inconsistent alerts on the Days since last backup metric.
Resolved an issue preventing Days Since Last Backup from alerting based on backup preference settings.
Resolved an issue preventing users from receiving Table Fragmentation (Percent) alerts for some servers.
Resolved an issue causing "SQL Server Status: Unable to Connect" email alerts for Availability Group Listeners that are not registered in SQL DM.
Resolved an issue preventing alerts on CPU spikes in Azure SQL Managed Instances even after adjusting the SQL Server CPU usage alert thresholds.
Resolved an issue causing <br> HTML tags to appear in the body of some alert email notifications.
Resolved an issue causing Get Minimum Permissions Batch to trigger alerts that there are deadlocks on monitored instances.
Resolved an issue causing SQL Server Long Running Job (Minutes) alerts to trigger for older events.
Resolved an issue causing Days Since Last Backup alerts to trigger for Availability Group secondary nodes after upgrading to SQL DM 14.0.1.
SQLDM-33392 Resolved an issue causing Long Running Job (Minutes) alerts to trigger below the configured threshold value and raise duplicate alerts for the same job run.
Resolved an issue causing data collection to fail after configuring alert thresholds.
Resolved an issue causing SQL DM to intermittently stop data collection and the Alerts view does not show any "Unable to Connect" alerts to notify the customer.
Resolved an issue causing email notifications for some alerts to display N/A rather than the host name.
DM Console
Resolved an issue causing the Alerts tab Group by Column option to retain its settings after reopening the SQLDM Console.
Resolved an issue preventing Distributor data from appearing in the SQL DM Console Replication view.
Resolved an issue causing the SQLDM Console to open only by running SQLdmDesktopClient.exe through a command prompt.
Resolved an issue causing the SQLDM Console to fail to refresh the data and display the message, "Exception Reading Permissions".
Resolved an issue where SQLDM Console users with Modify privileges could not click/open certain Query Plans to view additional information.
Installer
Updates the SQL DM client installer to include Microsoft.SqlServer.TransactSql.ScriptDom.dll.
General
Resolved an issue causing the incorrect SQL Server version from displaying for Azure SQL databases.
Resolved an issue causing a "Snapshot data is null" error on a reported server when refreshing the Sessions view.
Resolved an issue causing an error when the user attempts to open the Properties window for a VM server.
Resolved an issue in SQLdm Desktop Client-only installations where the required libraries for the OIDC feature are not installed.
Resolved an issue causing SQL DM to continue attempting to collect data on monitored servers in Maintenance Mode.
Resolved an issue causing the Custom Date Range Filtering to not return expected results when using long data ranges on the Session Details page.
Resolved an issue causing grooming to not clear all historical data.
Resolved an issue causing Collection snapshots to contain NULL values for monitored servers despite having successful connections.
Resolved an issue with grooming jobs retaining aggregated forecasting data beyond the configured retention period, resulting in unexpected repository growth.
Resolved an issue causing wrong account connections with Alternate Windows Auth context leaks between concurrent Collection Service threads.
Resolved an issue causing the OS Metrics WMI Test button to fail and display the message, "Value cannot be null. Parameter name: connection".
Resolved an issue causing WMI "Access denied" errors caused by impersonation context leakage between concurrent Collection Service threads when using Alternate Windows authentication.
Resolved an issue causing an error when reading permissions for a monitored server stating that the index is out of bounds of the array.
Reports
Resolved an issue causing the Details Session report to not return expected results when using long data ranges.
Resolved an issue causing the Database Growth Forecast report to not load the list of databases for certain instances.
Web Console
Resolved an issue causing incorrect functionality with the Group account permission in the SQL DM Web Console.
Resolved an issue preventing users from snoozing alerts in the SQL DM Web Console.
Resolved an issue in the SQL DM Web Console preventing proper application of Advanced Filters content when filtering by tags.
SQL Diagnostic Manager for SQL Server v14.1주요 버전2026년 5월 21일
기능
Introduces new AI-powered optimization workflows designed to help DBA diagnose and improve SQL Server performance faster and with greater confidence:
Use the AI Powered Query Optimization feature to optimize a single, problematic SQL query to reduce execution time based on your current schema and index structure.
Use the AI Powered Schema & Index Optimization feature to generate optimal index structures for a set of queries (up to five) to minimize cumulative execution time across all queries.
Use the AI Optimization History tab to view previous AI optimization sessions including queries analyzed, schema submitted, and AI recommendations. This tab provides a complete audit trail of all optimization activities performed in SQL DM.
These features are currently offered for SQL DM desktop version only.
SQL DM disables AI features by default. Contact your administrator to enable these features.
수정 사항
Alerts
Resolves an issue causing the daily "SQL Server Status: Unable to Connect" to falsely alert for all registered AG nodes.
Resolves an issue causing the "Where refresh occurred during a specific time frame" alert condition to disappear once saved in a rule.
General
Updates OAuth2 authentication functionality.
Resolves an issue causing the SQLdm Management Service to crash at random times.
Resolves an issue preventing an analysis from returning any results.
Resolves an issue causing SQL DM to display a permissions error when it really is a network issue causing the failure.
Resolves an issue causing the Historical Snapshots view to display some inaccurate information.
Resolves an issue causing SQL DM to grant db_owner permissions to some users when granting view access.
Web Console
Resolves an issue that allowed some user accounts without permission to the SQLdm repository or its host instance to access the Web Console.
The Web Console includes a Signal Icon in the upper-right corner of the window that indicates when new SQL DM product and marketing information is available.
SQL Diagnostic Manager for SQL Server v13.32026년 1월 8일
기능
Improved the web UI by including the following Resources tabs available in the Windows console:
Summary.
CPU.
Memory.
Disk.
Disk Size.
수정 사항
Alerts
Resolved an issue causing a false alert for the SQL Server CPU Usage (Percent) showing 100%.
Resolved an issue causing a false alert for the SQL Server Memory Usage (Percent) showing 100%.
Resolved an issue causing WMI connection errors.
No longer triggers false alerts generated from the AG primary replica and listener nor does it register the listener.
DM Console
Dashboard charts such as Memory Areas and Buffer Caches no longer show double values on the Y axis.
General
Resolved an issue causing Windows connection failures when multiple accounts are used with the Alternative Authentication option.
Resolved an issue causing the Tables & Indexes tab contents to not properly refresh.
Resolved an issue preventing the Analyze feature from properly displaying a complete SQL script in the list of queries.
Resolved an issue preventing some users from seeing new indexes upon upgrading to SQL DM 13.0.
Resolved an issue preventing some users from viewing their C drive in the Resources tab.
Resolved an issue preventing Azure Managed Instances from inclusion in historical snapshots.
SQL Server no longer remains in maintenance mode after scheduled maintenance time is over.
An issue causing the password to unmask when switching between authentication types is resolved.
The Properties dialog now properly displays the added Access Key, Secret Access Key, and Region values when registering an RDS instance.
The Query Execution Plan now properly appears and with correct colors.
SQL DM now displays the name and details of a stored procedure when viewing events.
Query Monitor
Resolved an issue causing Query Monitor to use an incorrect alternate authentication.
Resolved an issue that allows the Signature and Standard graphical views to display data even with Query Monitor disabled.
The alternative authentication option no longer causes SQL Server connection failures when using multiple accounts.
Reports
Resolved an issue causing the Table Growth Forecast graph to not include all data.
The Disk Space Usage report now correctly displays information for all drives and includes those drives in the report disk filter.
UI
The Connect to Repository dialog user interface no longer is shifted and hiding some controls.
Web Console
Resolved an issue preventing the Web Console from loading the Alerts tab and causing a delay when updating the server status.
Resolved an issue causing the Web Console to display incorrect transaction scaling.
The Web Console now correctly lists server dashboard charts with connection of the DMSO cluster database.
Web Console graphs no longer hide lower values because of graphical display.