Maveryx Test Automation Framework

Maveryx Test Automation Framework is a test automation tool that provides automated testing for functional, regression, GUI, data-driven and keyword-driven testing. It supports a wide range of applications from Desktop (Java, .NET, MFC, WPF) to Web (HTML/HTML5, JS, Ajax, GWT). Maveryx Test Automation Framework is able to inspect an application’s UI directly at runtime, to recognize test objects even if they have changed since test creation. The intelligent object recognition engine eliminates the need for recording actions or creating GUI Maps, Object Repositories, etc.

Maveryx Test Automation Framework Features

  • GUI Testing - Designed to fully exercise Graphical User Interfaces.
  • Functional Testing - Write functional requirements test scripts.
  • Regression Testing - Execute your tests many times without changing the script, even if the application has changed since test creation.
  • Keyword-driven Testing - Design your tests as executable Excel sheets or XML files.
  • Data-driven Testing - Use Excel, CSV and XML files to create data-driven test suites and implement data...

Latest News

Maveryx Test Automation Framework 2.3.0
Maveryx Test Automation Framework 2.3.0
Improves support for testing Web and Windows applications.
Maveryx Test Automation Framework released
Maveryx Test Automation Framework released
Automates functional, regression and UI testing for desktop and Web applications.

Prices from: $ 1,101.12

Maveryx uses a Node-Locked license type. A node-locked license for Maveryx lets you run the application on a specific machine or workstation. This license type is considered a single-user license...

Got a Question?

Live Chat with our Maveryx licensing specialists now.

Maveryx
As official and authorized distributors, ComponentSource supplies you with legitimate licenses directly from Maveryx.
Operating System for Deployment
  • Windows 10
  • Windows 8.1
  • Windows 8
  • Windows 7
  • Ubuntu 12.x or higher
  • Red Hat Enterprise Linux 5.x or higher
  • CentOS 6 or higher
  • Mac OS X