Compatibilità dotConnect for PostgreSQL

Compatibilità

PostgreSQL Compatibility
  • dotConnect for PostgreSQL supports PostgreSQL server since 8.0 version to 16, EnterpriseDB/EnterpriseDB Advanced Server/Postgres Plus Advanced Server/EDB Postgres Advanced Server, Pervasive Postgres SQL servers, Heroku Postgres.
Framework Compatibility
  • Microsoft .NET Framework 2.0, 3.0, 3.5, 4.0, 4.5, 4.6, 4.7, 4.8
  • Microsoft .NET Core 1.x, 2.x, and 3.x
  • Microsoft .NET 5.0/6.0/7.0/8.0
  • Microsoft .NET Compact Framework 2.0 and above
  • Mono version 2.0 and above
  • dotConnect for PostgreSQL is compatible with ADO.NET Entity Framework v1 - v6 and Entity Framework Core 1.x, 2.x, 3.x, 5.0, 6.0, 7.0 and 8.0 (PostgreSQL server 8.0 or higher is required for Entity Framework).
IDE Compatibility
  • Microsoft Visual Studio 2022
  • Microsoft Visual Studio 2019
  • Microsoft Visual Studio 2017
  • Microsoft Visual Studio 2015
  • Microsoft Visual Studio 2013
  • Microsoft Visual Studio 2012
  • Microsoft Visual Studio 2010
  • Microsoft Visual Studio 2008
  • Embarcadero Delphi Prism
  • CodeGear RAD Studio 2007