Compatibilité de Highcharts JS

Compatibilité

Type de produit
  • Composant
Type de composant
  • JavaScript
  • Angular
  • AngularJS
  • Réagir
  • Vue.js
Navigateurs pris en charge
  • Internet Explorer 6.0+
  • Firefox 2.0+
  • Chrome 1.0+
  • Safari 4.0+
  • Opera 9.0+
  • iOS (Safari) 3.0+
  • Navigateur Android 2.0+ *)

*) Le navigateur Android 2.x a un support limité.

Pré-requis

Highcharts is a standalone library, which means that it does not require any additional frameworks or plugins to work. It is solely based on native browser technologies, and all core functionality runs in the browser. As it is a front-end library, Highcharts can be used with any server that can serve static files. It needs only the core highcharts.js script to run.

Highcharts works on all modern browsers and mobile devices. Legacy browsers - primarily IE 6-8 - are supported using polyfills and the old IE module.

There are Highcharts wrappers available for frameworks such as React and Vue, as well as for native iOS and Android development.