Compatibilité de PDFlib

Compatibilité

Component Type
  • .NET Class
  • .NET Core
  • DLL
  • Java Class
Java on all platforms
  • Java 8+
Windows
  • Microsoft Windows 11
  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2016
  • Microsoft Windows 10
  • Microsoft Windows Server 2012
.NET
  • Windows x86, Windows x64, Linux x64, macOS x64 and arm64, Alpine Linux x64
  • .NET Standard 2.0, e.g. .NET 6/7/8
  • .NET Framework 4.6.1 and above
Linux
  • GLIBC 2.12 or above and libstdc++.so.6.0.21 or above based system on x86/x64
  • GLIBC 2.27 or above based system on ARM64
Alpine Linux
  • Alpine Linux 3.4+ x64
macOS
  • macOS 10.9+ x64/ARM64
FreeBSD
  • FreeBSD 12 x64
AIX
  • AIX 7.1+
IBM System i
  • IBM System i 7.2+
IBM System z
  • z/OS 2.4+ with USS (32-bit/64-bit) or MVS (64-bit)
zLinux
  • zLinux 64-bit
  • GLIBC 2.19+ based system
Compatible Containers
  • Microsoft Visual Studio 2022
  • Microsoft Visual Studio 2019
  • Microsoft Visual Studio 2017