Compatibilidade do Heimdall Database Proxy

Compatibilidade

Supported versions of Linux include vendor supported versions of (in alphabetical order):

  • Alpine
  • Amazon Linux 2+
  • Centos
  • Debian
  • Oracle
  • Redhat/Fedora
  • Suse
  • Ubuntu

Pré-requisitos

In order to install and use Heimdall, the following will be needed:

  • A login for the database. For full capabilities, this user should have the ability to login, execute a health check query, access (or create) a schema/database of "heimdall", and have full access to this schema or database. This is used for health checking and various other features such as lag detection.
  • Understanding of the configuration of the application, and how to adjust what database it points to. This varies from application to application, but a few common locations for this are:
    • The IIS configuration for a .net application, under connect strings
    • a configuration json file
    • a configuration PHP file
  • Preferably a test environment to test with before going into production.
  • A Linux server or Docker environment (see below for deployment options) with at least 20GB of space