SourceGear Vault Standard 的相容性

相容性

Client

Vault Clients require at least the .NET Framework 2.0 and are supported on these operating systems:

  • Windows XP Professional (SP3)
  • Windows Server 2003
  • Windows Vista (Business and Ultimate)
  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows 7
  • Windows 8
  • Windows 8.1
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows 10
  • Windows Server 2016
  • Windows Server 2019
Cross Platform Client

Vault Cross Platform Clients will only work with a Java(TM) Runtime Engine 8.0 Update 181, Java 9, Java 10, and Java 11, and have been tested on the following operating systems:

  • Apple OS X Lion 10.7 (and later) configured with the Oracle Java 8 JDK, Oracle Java 9 JDK, Oracle Java 10 JDK, and Oracle Java 11 JDK
  • Ubuntu 16.04 (and later) x86_64 with Open JDK 8, Oracle's JDK 8, Open JDK 10, Oracle's JRE 10, Oracle's JDK 11
  • Open SUSE 13 (and later) x86_64 with Open JDK 8, Oracle's JDK 8, Open JDK 9, Oracle's JDK 9, Open JDK 10, Oracle's JRE 10, Oracle's JDK 11
  • Fedora 20 (and later) x86_64 with Open JDK 8, Oracle's JDK 8, Open JDK 9, Oracle's JDK 9, Open JDK 10, Oracle's JRE 10, Oracle's JDK 11
Web Client

Vault Web Clients are supported on these browsers:

  • Internet Explorer 10 and 11
  • FireFox 23.0 and above
  • Chrome 29.0 and above
  • Safari 6
Server

The Vault Server requires at least the .NET Framework 4.5 and is supported in both the 32-bit and 64-bit versions of these Windows operating systems:

  • Windows Server 2008 R2
  • Windows 7 (Professional and Ultimate)
  • Windows 8 (Pro and Enterprise)
  • Windows 8.1 (Pro and Enterprise)
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows 10
  • Windows Server 2016
  • Windows Server 2019

The Vault Server Database requires a Microsoft SQL Server.

  • SQL Server 2005 (SP2) or SQL Server Express 2005 (SP2)
  • SQL Server 2008 or SQL Server Express 2008
  • SQL Server 2008 R2 or SQL Server Express 2008 R2
  • SQL Server 2012 or SQL Server Express 2012
  • SQL Server 2014 or SQL Server Express 2014
  • SQL Server 2016 or SQL Server Express 2016
  • SQL Server 2017 or SQL Server Express 2017
  • SQL Server 2019 or SQL Server Express 2019

The Vault Server also requires a version of Microsoft IIS.

  • IIS 7.0 or higher with .Net 4.5 Full Framework for Server and Development