Universal Data Access Components (UniDAC) 的相容性

相容性

Database Server Compatibility
  • Oracle
    • Servers: 18c, 12c, 11g, 10g, 9i, 8i, 8.0, and 7.3, including Oracle Express Edition 11g and 10g
    • Clients: 18c, 12c, 11g, 10g, 9i, 8i, 8.0, and 7.3
  • Microsoft SQL Server
    • Servers:
      • SQL Server 2017/2016/2014/2012/2008 R2/2008/2005 (including Express edition)
      • SQL Server 2000 (including MSDE)
      • SQL Server 7
      • SQL Server Compact 4.0, 3.5, 3.1
    • Clients:
      • SQL OLE DB and SQL Native Client
  • MySQL Server
    • Servers: 8.0,6.0, 5.6, 5.5, 5.1, 5.0, 4.1, 4.0, and 3.23
    • Embedded servers: 8.0, 6.0, 5.6, 5.5, 5.1, 4.1, and 4.0
  • MariaDB
    • MariaDB 5.x
    • MariaDB 10.x
  • Microsoft Azure Database for MySQL
  • Amazon Aurora
  • InterBase Versions XE3+
  • Firebird: 1.x, 2.x, 3.x
  • PostgreSQL Versions 8.0 up to 11
  • Microsoft Azure Database for PostgreSQL
  • SQLite Version 3.0 and higher
  • MongoDB
    • Servers: 3.2 and higher
    • Clients: 1.3.5 and higher
  • Amazon Redshift
  • NexusDB Versions 4.x
  • Microsoft Access Versions 95, 97, 2000, 2003, 2007, 2010, 2013 and 2016
  • DB2 Versions: 8.0 and higher
  • DBF
  • Sybase Adaptive Server Enterprise Versions: 12.5.4 and higher
  • Sybase Advantage Database Server Versions: 8.0 and higher
  • Any database using OBDC provider
IDE Compatibility
  • Embarcadero RAD Studio 10.3 Rio (Requires Update 2)
  • Embarcadero RAD Studio 10.2 Tokyo
  • Embarcadero RAD Studio 10.1 Berlin
  • Embarcadero RAD Studio 10 Seattle
  • Embarcadero RAD Studio XE8
  • Embarcadero RAD Studio XE7
  • Embarcadero RAD Studio XE6
  • Embarcadero RAD Studio XE5 (Requires Update 2)
  • Embarcadero RAD Studio XE4
  • Embarcadero RAD Studio XE3 (Requires Update 2)
  • Embarcadero RAD Studio XE2 (Requires Update 4 Hotfix 1)
  • Embarcadero RAD Studio XE
  • Embarcadero RAD Studio 2010
  • CodeGear RAD Studio 2009 (Requires Update 3)
  • CodeGear RAD Studio 2007
  • CodeGear RAD Studio 2006
  • Borland Delphi 7
  • Borland Delphi 6 (Requires Update Pack 2 – Delphi 6 Build 6.240)
  • Borland C++Builder 6 (Requires Update Pack 4 – C++Builder 6 Build 10.166)
  • Lazarus 2.0.2 and Free Pascal 3.0.4 for Windows, Linux, macOS, FreeBSD for 32-bit and 64-bit platforms
Component Type
  • VCL