Kendo UI + Telerik UI for JSP Compatibility

Compatibility

Operating System
  • Windows Server 2016
  • Windows 10
  • Windows 8.1
  • Windows 8
  • Windows Server 2012
  • Windows 7
  • Windows Server 2008
  • Windows Vista
  • Windows Server 2003
  • Windows XP
  • Windows Phone 8.0+
  • OS X 10.5+
  • Android 2.3+
  • iOS 6.0+
Product Type
  • Component
Component Type
  • JavaScript
  • Angular
  • AngularJS
  • jQuery
  • React
  • Vue.js
  • JSP Server Wrappers
Browser Compatibility
  • Microsoft Edge 20+
  • Microsoft Internet Explorer 9+
  • Chrome
  • Firefox
  • Opera 15+
  • OS X Safari 6.2.6+

Notes on Operating System Support:
Hybrid mouse and touch-screen devices are supported; for example, Internet Explorer 10, Chrome and Firefox on Windows 8.
JavaScript should be enabled on all browsers so that they can be allowed to run scripts.

Prerequisites

The current official version of Kendo UI requires jQuery 1.12.4. Usually, each newly released jQuery version introduces breaking changes and is not compatible with the existing Kendo UI versions. In such cases, use the previous jQuery version until the next official Kendo UI version that resolves the issue is released. Normally, the jQuery version that is shipped with the Kendo UI service packs is not changed but is updated in major releases.