dotUltimate Compatibility

Compatibility

ReSharper

Visual Studio Integration
  • Microsoft Visual Studio 2019
  • Microsoft Visual Studio 2017
  • Microsoft Visual Studio 2015 Update 3
  • Microsoft Visual Studio 2013 Update 5
  • Microsoft Visual Studio 2012 Update 3
  • Microsoft Visual Studio 2010 SP1

Note: Visual Studio Express editions are not supported.

Visual Studio intergration Operating Systems
  • Windows: 7, 8, 8.1, 10
  • Windows Server: 2008 R2, 2012, 2012 R2, 2016, 2019
Command-line tools Operating Systems
  • Windows: 7, 8, 8.1, 10
  • Windows Server: 2008 R2, 2012, 2012 R2, 2016, 2019
  • Mac OS: 13+
  • Linux: Debian 9+, Ubuntu 16.04+, CentOS 7+, Fedora 30+, Linux Mint 18+, openSUSE 15+, Alpine Linux 3.10+, Oracle Linux 7+, SUSE Enterprise 12 SP2+, Red Hat Enterprise Linux 6/7/8
Command-line tools Framework
  • .NET Framework 4.6.1 or higher
  • .NET Core 3.1 or higher

ReSharper C++

Operating Systems
  • Windows: 10, 8.1, 8, 7
  • Windows Server: 2019, 2016, 2012 R2, 2012, 2008 R2
Visual Studio Integration
  • Microsoft Visual Studio 2019
  • Microsoft Visual Studio 2017
  • Microsoft Visual Studio 2015 Update 3
  • Microsoft Visual Studio 2013 Update 5
  • Microsoft Visual Studio 2012 Update 3
  • Microsoft Visual Studio 2010 SP1

Note: Microsoft Visual Studio Express editions are not supported.

Frameworks
  • .NET Framework 4.6.1 or higher
Command-line tools Operating Systems
  • Windows: 10, 8.1, 8, 7
  • Windows Server: 2019, 2016, 2012 R2, 2012, 2008 R2
  • Mac OS: 13+
  • Linux: Debian 9+, Ubuntu 16.04+, CentOS 7+, Fedora 30+, Linux Mint 18+, openSUSE 15+, Alpine Linux 3.10+, Oracle Linux 7+, SUSE Enterprise 12 SP2+, Red Hat Enterprise Linux 6/7/8
Command-line tools Framework
  • .NET Framework 4.6.1 or higher
  • .NET Core 3.1 or higher

Rider

Operating systems (64-bit distributions only)
  • Windows: 10, 8.1
  • MacOS: 13+
  • Linux: Debian 9+, Ubuntu 16.04+, CentOS 7+, Fedora 30+, Linux Mint 18+, openSUSE 15+, Alpine Linux 3.10+, Oracle Linux 7+, SUSE Enterprise 12 SP2+, Red Hat Enterprise Linux 6/7/8
Framework
  • .NET Framework 4.6.1 or higher
  • .NET Core generates automatically while installing

Profiling tools

dotMemory, dotCover, dotTrace and their respective remote profiling agents require .NET Framework 4.6.1 or higher to be installed.

dotMemory and dotTrace allow profiling any .NET application that targets the following frameworks:

  • .NET Framework 2.0, 3.0, 3.5, 4.0, 4.5, 4.6, 4.7 or 4.8.
  • .NET Core 1.0, 1.1, 2.0, 2.1, 2.2, 3.0 or 3.1

dotPeek requires .NET Framework 4.6.1 or higher to run.