Highmaps JS Compatibility

Compatibility

Product Type
  • Component
Component Type
  • JavaScript
  • Angular
  • AngularJS
  • React
  • Vue.js
Supported Browsers
  • Internet Explorer 6.0+
  • Firefox 2.0+
  • Chrome 1.0+
  • Safari 4.0+
  • Opera 9.0+
  • iOS (Safari) 3.0+
  • Android Browser 2.0+ *)

*) Android browser 2.x has limited support.

Prerequisites

Highcharts is solely based on native browser technologies and doesn't require client side plugins like Flash or Java. Furthermore you don't need to install anything on your server. No PHP or ASP.NET. Highcharts needs only the highcharts.js core to run.

Highcharts and Highstock work in all modern browsers including mobile devices and Internet Explorer from version 6. Standard browsers use SVG for the graphics rendering. In legacy Internet Explorer (IE8 and before) graphics are drawn using VML.

Highcharts and Highstock run on any server that supports HTML. You can even run Highcharts locally from a filesystem, since all the rendering is done locally in a browser.